Sugar Creation Kit/sck/Advanced Topics

From Devel wiki for Sugar Labs
Jump to: navigation, search


Sweets Distribution

Sugar Network Tutorial

  • Annotated screen shots with Links

Sweets-Getting Started

Click on title ^ to go to topic
  • Some ideas on how to present SWEETS. (Inkyfingers)
  • look at Infrastructure for an overview.

Sweets Distribution

Click on title ^ to go to topic
(Sweets Distribution is easier to use for Ubuntu' and its Derivatives (Adding an additional Repository to apt) as the packages are pre-configured, ready to use.)
(Developed for Trisquel-sugar-Toast )


Click on title ^ to go to topic
Debian, Ubuntu, Fedora, Mandriva, openSUSE, and Gentoo
(This guide describes how to run Sugar using Sugar Packaging Management System, Sweets.)
Request for better Documentation of installs
Log of Installation of sugar-sweets 0.88 and 0.94 on f16-GNOME3-shell
(For developers)

Sugar Network

Collaboration support for Internet-less environments (but not only)

Harmonic Distribution

* The possibility to launch Base Software in heterogeneous
  software and hardware environments.
* Using Base Software, provide access to various Content
  (Sugar activities, artifacts created by Sugar activities, books, etc.)
  created within the Sugar community.
* Using Base Software, provide collaborative functionality to
  support Social activity around the Content.
* Instruments and workflows to adapt Content and Base Software
  to specific needs that Sugar Deployment might face,
  including extreme ones like off-line environments and restricting
  • [Sugar-devel] [SWEETS] Testing collaboration related fixes 05/07/2012
Hi all!
Following the plan for Harmonic Distribution v0.2 (which will be a basis
for Sugar Distribution to use in peruvian pilot), in Sugar Shell code
were made fixes that are intended to make Telepathy (everything related to
Neighbourhood view and Sugar Activities sharing/joining) more stable
(that was broken since global redesign started after 0.88 release).
Fixes are accessible from SweetsDistribution:Factory repository. Follow
regular Sweets Distribution installation instructions[1] to install
fixed Sugar Shell on all supported platforms[2].
Some visible changes in F1 view:
* the number of buddies should be increased from ~20 to 70-90
  some Sugar versions (maybe 0.90-0.92) don't publish information about
  nickname/colors on regular basis; this information are being stored on
  disk for now
* for some buddies, server still don't have information about colors
  (replaced by gray) and nick names (jabber ids)
If you have a time and want to help Puno deployment pilot, please,
consider possibility to install sweets-desktop from Factory repository
and do some testing of collaboration functionality.

Some tips:

* while interacting with another buddies, make sure that all
  participants use Sweets Distribution (some F1 buddies might misbehave)
* the good criteria of stability level of new Sugar is comparing with
  how collaboration happen in 0.88 Sugar.
Source code, for interested in people, can be found in top commits from:

[1] Sweets_Distribution#Installation
[2] Sweets_Distribution/Supported_platforms

-- Aleksey
Sugar-devel mailing list


BoxGrinder Build is an easy to use command line tool to create appliances (virtual images) from simple plaintext appliance definition files. BoxGrinder can produce appliances for a variety of virtual and cloud platforms using plugins supporting technologies such as VMware or EC2.


  • used to build non-live CD/DVD isos
Pungi needs to run on the arch it is composing, as root, and with an install of what it is composing, eg if you are composing Fedora 8, you need to be running Fedora 8.
This is so that the correct userland tools are used to create the images and such used by anaconda.
The eventual usage of pungi will most likely be in mock chroots to facilitate this.
It needs to run on the arch it is composing due to how anaconda-runtime determines what files to put in the boot images at this time.
Currently the releases of pungi are designed to run on an updated Rawhide system. Development of pungi always tracks Rawhide.
The following sections..." assume you have installed the mock package and prepared the mock chroot"

Build a boot.iso

  • "This section provides instruction on creating PXEboot and boot.iso images"

Build a DVD.iso

  • "This section assumes you have installed the mock package and prepared the mock chroot"

How to Create a Fedora Install ISO


Click on title ^ to go to topic
(Very Advanced)
Koji is the software that builds RPM packages for the Fedora project


Mock creates chroots and builds packages in them. Its only task is to reliably populate a chroot and attempt to build a package in that chroot.

How to create a Fedora install ISO for testing

GnomeLove Jhbuild Introduction

How to create an RPM package

  • How to create an RPM package in Fedora

  • better j-build


The Sugar Learning Platform is a leading learning platform developed for the One Laptop per Child project and used every day by nearly 3 million children around the world. With Sugarizer, you could discover the Sugar Learning Platform on any device: from the tiny Raspberry PI to the small Android/iOS tablet or the bigger PC/Mac. Enjoy the experience and help us reach every children on every device in every country. Sugarizer is distributed on the form of 3 components:

Thin Client: remote access to Sugarizer using a browser,
Client: Sugarizer running locally,
Server: place to run remote Sugarizer features.
  • Write your own web activity:


(Work in progress);a=summary

"Friday, April 25, 2014

Sugar says hello to cordova

Sugar labs - award-winning Sugar Learning Platform has been around for years now creating wonders in lives of many little ones and young, providing them with a window to a new world to explore new things. This fabulous open source community consists of some really cool and hard working people at the back end, thinking continuously about as to how to make sugar better than ever before.So here props up another idea.. why not make a cordova framework for sugar platform as android, windows and ios have ?? The obvious question that now arises in someone's mind who isnt yet familiar with cordova or phonegap would be - how is that gonna help sugar ? Well, the answer is pretty simple.All the activities and the code for sugar is currently in python because thats the language the software was made in.With cordova, all the web developers can make activities in html,css and js while not bothering about interaction with the physical hardware devices like camera etc.. the cordova wrapper would do that for you."


Advanced - Used by Sugar Developers
I installed Fedora 18 last night, and I have to say I like sugar-build
more and more.  With just this steps in a clean F18 you get Sugar
running and ready to hack each part of it:  Kudos Daniel Narvaez!
  Re: [Sugar-devel] F18.. go sugar-build, go! 01/18/2013 03:56 PM 
sudo yum install git
git clone git://
cd sugar-build
make build
make run
located below on this wiki page


NEW 09/25/2014

L10n Translations

There is a git user named "pootle" that acts as the proxy by which all
PO file translations are committed from the Pootle server.  Please
make pootle a committer on the repo and I will make the connections
between git and the Pootle server.
Some "best practices" about working with git and Pootle are described here.
 Translation Team Best Practices

UFI booting-self-signed-linux-kernel booting-self-signed-linux-kernel

"The procedures for how to boot a self-signed Linux kernel on a platform so that you do not have to rely on any
external signing authority."

systemd for Administrators

"Resource Management in one way or another has been available in systemd for a while already,
so it's really time we introduce this to the broader audience."


"Vala is a new programming language that allows modern programming techniques
to be used to write applications that run on the GNOME runtime libraries,
particularly GLib and GObject."

SAMdroid (talk) Is this really relevant to Sugar?


Click on title ^ to go to topic
  • Very Advanced
"Groupthink is a library of self-sharing data structures written in python and shared over dbus.
Together with the D-Bus Tubes provided by the Telepathy framework, this enables data structures to be shared over a network."

OLPC XO links and Notes

Click on title ^ to go to topic

Testing Introductory Page

Help/Info Wiki Page

Release 13.1.0

Release 14.1.0

build 8, a development release, not final,
based on Fedora 20,
based on Sugar 0.103.2, see release notes,
enabling OpenGL ES 2.0,
enabling the second core of the dual core CPU, which improves responsiveness, with only a slight increase in power draw,
support for new backlight LEDs to be used by factory,
support for new 16 GB eMMC internal storage,
support for new LiPoly battery used by factory,
the GNOME desktop has been replaced by the MATE desktop, because GNOME in Fedora 20 requires a full implementation of OpenGL,
Wikipedia EN and ES have been replaced by the Simple English Wikipedia activity,

Install of Release 14.1.0 for XO-4

  • Mate 1.8.1 and Sugar
  • Upgraded from 13.2.0
With the help of Cerlyn and Quozl on #sugar 02/15/2015

Prepare the USB or SD drive:

Note use a small 2 to 4 GB USB if possible.
Some cheap 8 GB USB's will not work here. (I had one not boot for me)
  • Download 41008o4.zd,
  • Download,
  • Download Firmware:

Save the files to the top directory of the drive,

  • Insert the Drive in the XO-4
Be sure it is plugged in to power and has a fully charged battery.
  • Check that the drive contains the 3 files; 41008o4.zd and q7c04.rom
If you press ESC while the startup sound plays to get to an Open Firmware prompt,
type "dir u:\" there to see the files on the USB stick
  • Start installing:
Turn off the XO-4
Hold down all four game keys above the power button,
Turn on the laptop,
Wait for the message Release the game keys to continue,
Release the game keys.
Installation progress will be displayed. Green colour will fill grey blocks.
It will take about five minutes. Once finished, the laptop will reboot automatically.
You may remove the USB or SD drive during or after the reboot.

Update Firmware

  • Do this if reboot fails.
  • At OK prompt after reboot:
flash u:\q7c04.rom
  • required to use this new release
  • yum update will bring in a later version of sugar.

0.104 Release Notes

XO-4 is still available

Tiny Core Linux on the XO

Data Collection from the Sugar Journal


  • The Harvest system is being used to gather some basic stats; A visualization tool will be developed to enable stakeholders (funders, administrators, and classroom teachers) to monitor these data.

Olpc os builder

  • "utility that allows you to build operating system (OS) images for XO laptops"

XO-4 Touch

XS Community Edition

  • School Server - Community Edition (XSCE) project
Software :

Install instructions

Updated 0116/2014

Git Instructions!workflow-forking

Install XSCE on an intel NUC

Dropbox working with the Journal

"If you don't have a Dropbox account, go to and sign up.  If you're a heavy Dropbox user,
I highly suggest creating another account just for the XO.
As with all things Linux, there are a few scenarios and use cases to consider. 
Here's a distillation, from the easiest installation and on.
1.  Gnome Desktop only, keeping Dropbox on the nand.  No USB drive required.
You're looking for an easy way to transfer notes, small files, etc. between the XO and your "regular" computers
 without having to constantly mess with USB drives.
2.  Gnome Desktop and usage under Sugar in the Terminal.  No USB drive.
The above scenario applies to you, but you'd also like to be able to access /home/olpc/Dropbox under Sugar in the Terminal.
3.  Up to 2 GB of storage as well as Sugar Journal integration.  USB drive required."
  • September 18, 2010, 10:10:02 AM by anna

Testing Dextrose in a virtual machine

  • Download Image; KVM; VirtualBox

Dextrose Building

Dextrose uses olpc-os-builder, a tool create by OLPC to build official and customized system images.
The Dextrose git repository contains, olpc-os-builder, local customizations specific to Dextrose,
and fixes and enhancements waiting to be pushed upstream. 

XSCE in VirtualBox

  • 3 Importable XSCE VirtualBox builds:

m-anish VM

  • Local download:
Uploaded with permission
  • Click on the XSCE.ova icon and It begins import into VirtualBox (If you have it installed)
VirtualBox Site:
Tested in f20 VirtualBox 11/19/2013
  • Google download:
b_1364170741.ova (1.6G)
Error creating thumbnail: File missing
(with VirtualBox XSCE window shown in right small window)
  • [Server-devel]11/18/2013 The three step XSCE demo!
Hi, Had some time on my hand this week to try out XSCE in a virtual environment. It actually worked out pretty well, and now there's a working appliance. Here's the three step XSCE demo!
Step #1 - Download and install Virtualbox
    Head to to download the Virtualbox package for your OS.
    Install instructions may vary for different platforms but should be pretty straightforward.
Step #2 - Download and install the XSCE appliance
    Download the XSCE Virtualbox appliance from here (approx 1.6 GB)
    [optional] Verify the md5sum to see if the image is not corrupt - 56a4f141b564b0d2bd65c543a5e585c6
    Open Virtualbox. Go to File -> Import Appliance.
    A dialog will appear asking you to "Open Appliance"
    Select the file you just downloaded "b_1364170741.ova"
    Click "Next" and then click "Import"
    A new virtual machine will get created
Step #3 - Play!
    Start the virtual machine just created. It will open a window, and an OS will appear to boot.
    Wait till it boots. Once it has booted, a login prompt will appear in a text console. Your XSCE is now up and ready!
    To test/demo, on the host OS (i.e., the one where you are running the virtualbox software in) open a browser
        XSCE homepage: http://localhost:3380/
            From the homepage you should be able to navigate to Internet In A Box. This image contains a test dataset.
            The link to the moodle homepage will NOT work. To access moodle, go to http://localhost:3380/moodle/login/index.php. I am not able to login, and there seems some issue with the homepage loading.
        Administrative GUI: http://localhost:9990 (username=root, password=admin)
        Server monitoring tool - Munin: http://localhost:3380/munin (username=admin, password=munindxs)
        To check the authserver, go to http://localhost:5000/ (It will probably say "No Sugar platform detected, please register your laptop")
    This is only meant to be a quick demo to see what an XSCE is on your laptop/PC.
    I didn't setup root login (or atleast don't know the password to it). So you won't be able to login to the XSCE once it's running. Should not be a huge issue just for end-user demo purposes.
    This is just a weekend hack, I did based on a Vagrantfile supplied by Santi. At this moment, this is not officially supported or anything (but as far as I know in my testing, it works!)
    If this is a useful thing to maintain (based on feedback to this thread :-) ) I (or somebody else) can propose this as a feature for 0.5/6. So there are officially supported demo appliances.
    A wiki page is in the works. 
Please try it out and let me know what you think of it!
Thanks, Anish
  • added Info ///18/2013
It is a vagrant generated virtual machine so:
- the user/password are vagrant/vagrant
- user 'vagrant' is in sudoers group
- ssh access is possible using port 2222 in localhost
  • I have an entry in .ssh/config so I can access using `ssh vagrant`:
Host vagrant
 User vagrant
 Port 2222
 UserKnownHostsFile /dev/null
 StrictHostKeyChecking no
 PasswordAuthentication no
 IdentityFile "~/.vagrant.d/insecure_private_key"
 IdentitiesOnly yes
 LogLevel FATAL

The insecure private key is available Github [1].


Contributing to DXS using Github

  • YouTube:

XSCE 5.0 (aka 0.5)

  • SchoolServer.vdi 6.6GB 6.6GB
  • Release Announcement:
Error creating thumbnail: File missing
  • On 1/16/2014 11:45 AM, Curt Thompson wrote:
"Username: xsce
Root/sudo password:
I have this set up now in "appliance mode", considering people may want
to try it out without running a dhcp server and possibly breaking their
network(s).  Single NIC, bridged. (Apparently running this DHCP server should not cause issues with others as schoolserver's dhcp server is set to be 'not authoritative' but I will leave it this way for now)
If you wanted to change the mode, I believe you only have to go into the
machine settings in VirtualBox, add a NIC, boot up the VM and rerun
./runansible as root from ~/xsce

  • Reply [Server-devel] XSCE 5.0 (aka 0.5, upgraded from 0.4) VirtualBox Files
Unfortunately this XSCE VM project is on hold for me for a week or so as I'll be in Haiti.
I can add anyone who wants to work on it to the "sharing" list so the files could sync between our Google Drives.
I would only ask that if changing the original files whatever is done is documented and emailed to me (and/or this list).
IIAB - I noticed that EN wikipedia was missing too, I think the EN module is easily added.  Probably you can copy it from a full version of IIAB into the relevant directory and it will show up in the list.
Midori is pointing to schoolserver/syans as the last location - 
I previously had some proprietary content served from that location but removed it for sharing purposes and forgot to clear the history, I guess.
 I installed Firefox for  in-browser PDF reading (also related to the proprietary content).
OVA is probably a better distribution method unless people prefer to sync the files in our Google Drives.
I don't claim any ownership of these files, so feel free to create and share an OVA, link to them, etc.  OVA is almost certainly a better option for 'to the world' releases of the XSCE test VM on blogs, etc.
Thanks Curt Thompson"
  • Original Message: 1/16/2014 12:06 PM, :
"downloaded SchoolServer.vdi it was 6.6 GB
used it as existing disk. in new (Oracle VB 4.2.14)
logged in and worked fine
-Need to use firefox to see it. Midori browser is pointing  to .... /syans/  (spelled that way)
works also if delete that part of path in browser
-Moodle did not start
-iiab wikipedia is in guarani  cannot seem to find english
I did an export to a 3.2 GB schoolserver.ova that imports back into VB
- could that be a better way to distribute this?
--1024 memory with 10GB dynamic expanding HD / NAT"

XS Schoolserver 0.7

Click on title ^ to go to topic

Install of XS 0.7 on Centos-6.4

  • Terminal output of install 08/02/2013
  • Full instructions used:


Re: [support-gang] Status update of the installation of the new school server and IIAB at Rahnuma School Karachi
On 08/04/2013 06:00 AM, Braddock wrote:
 When the IIAB registers via DHCP it advertises its name as "know", and if the DHCP server and the DNSserver talk to each other the DNS server will resolve the name.
dnsmasq does this, so I suspect that might be what School Server runs?)
The only down side to this is that if you reboot the school server,you may find you need to then reboot the IIAB device so it gets afresh DHCP lease because the school server may forget it exists. 
Tony Anderson:
The school server is gateway and dns for the XOs and can certainly resolve http://know to a fixed address, which is the more orthodox way to do this.
Incidentally, I believe the problem with the wiki is that the url is http://schoolserver/wiki4schools/ not http://schoolserver/wiki.
Normally, the XOs access everything from the Browse home page so that keyboard entry of urls is not needed. However, because of the xo-custom script problems this was not set up. 


OLPC Manual
Help Activity Refresh
Manuals Info

Adobe Flash on the XO-4

"It says that for the XO-4 (but not the same for the 1.75 OLPC will provide the player because it has paid the fees to Marvell.
Copied form the wiki page but without the links supported...
OLPC support will provide a at the same time as providing access to the video drivers.
download and install the video drivers,
copy the file to the XO-1.75 or XO-4,
start the Terminal Activity,
copy the plugin, paste this: 
sudo cp /usr/lib/mozilla/plugins/
wrap the plugin, paste this: 
yum -y install nspluginwrapper && \
/usr/lib/nspluginwrapper/npconfig -n \
-p nswrapper_32_32 \
-d /usr/lib/mozilla/plugins-wrapped \
-i /usr/lib/mozilla/plugins/

Internet in a Box

Start iiab-server

# iiab-server
werkzeug --  * Running on
werkzeug --  * Restarting with reloader
  • Enter address in browser


  • Click on screenshot to enlarge; hit <== return arrow on browser to return
Installed on a i7 Laptop with the above installation link
This is a reduced version [1] of Internet in a Box (not the full 1 TB )
[1] IIAB_QuickStart_Sampler_20130809.tgz
Error creating thumbnail: File missing
Error creating thumbnail: File missing
  • iiab Main Menu
  • iiab-books Project Guttenburg
Error creating thumbnail: File missing
Error creating thumbnail: File missing
  • iiab-Video
  • iiab-settings (credits)

Also see:
Error creating thumbnail: File missing
  • Browse looking at local School Server on a XO-4 with XSCE RC-1 installed with USB containing /knowledge directory of iiab inserted

Unleash Kids

" all-volunteer Unleash Kids efforts shipping XO-4 community kits (hopefully including XS Community Edition!) to volunteers a bit later this summer, at the most minimal cost we can muster,
to be announced soon @"

Forth Lessions

  • A series of lessions on the OLPC wiki

Kernel Userspace Interfaces


  • ARM-Flock (you tube pbrobinson) Streamed live on Aug 9, 2014
fedora 17 and fedora 18 (arm/armhpf)
How to Create an ARM Remix


Firmware Updater

Ubuntu on a TrimSlice

  • Testing of TrimSlicePro
  • Testing of TrimSlice H250
Install of Ubuntu to 320 GB HD
Install of Ubuntu to a SDXC Card


  • TrimSlicePro Setup Booted from 64 GB SDXC Card in front slot
(SDXC card is expanded to 30 GB with gparted)

TS with Sugar.JPG

  • TrimSlicePro Running KDE-Desktop -plus sugar-emulator (0.90.1)
Beautiful Display on Samsung SyncMaster S20B350 HDMI 1600x900 @60Hz PP

Fedora on a TrimSlice

Fedora with XFCE
f17-arm RC-1:
Boot from CD:


f17 Nightly Images
live media creator on arm
Trimslice Pro and H250
Serial interface ONLY
  • Mac-Trimslice Pro Connections:
Nice Terminal Emulator for Mac:
  • Connection Diagram:
[MacBookPro USB port]---[usb to serial adapter (&)]---[null modem]--[serial cable]--(TrimSlice serial to mini cable]--[TrimSlice serial port]
(&) DYNEX USB_PDA/Serial Adapter (Dynex DX-UD889)
  • Console Speed 115200 bps, 8n1,
  • root password: -Displays in serial terminal-
  • Note these are experimental FOR TESTING ONLY - Still in development; use with caution
  • The kernel used does not support startx
No graphical interfaces are available at this time for TrimSlicePro and TrimSlice -h
  • dd will write a live USB but it will not boot in arm devices.
works in intel PC's
  • livecd-tools does not work
SD Card Install
This is a Fedora 17 Hard Float Trimslice Image suitable for writing to an SD card and placed in the Trimslice's Full Size SD slot (Front slot)
and booting without further modification.
Write with xzcat file.xz > /dev/mmcblkX, put in the device, and you're ready to go. Boots to a serial console.
Most of the SD card images can be used with a USB storage device drive using the following method:
Write the image to both the USB storage device and an SD card. IE, write the image using xzcat file.xz > /dev/sdX then xzcat file.xz > /dev/mmcblkX.
Once written, use a partition editor such as fdisk to delete the VFAT partition from the USB drive and the Linux partition from SD card.
Plug the SD and USB storage into your ARM device and power up. 
The ARM system will load any applicable bootloader pieces, kernel, and initramfs from the SD card, but use the USB storage for the root filesystem.

Nearly images are self-sufficient, but a kernel tarball is optionally available with the contents of the image's /boot and /lib/modules directories.
These can be used in conjunction with the tarball root filesystems to create your own images.
  • Resizer Script and systemd file
expects 2 partitions on SD card; will not work if a 3rd exists


Raspberry Pi / RPi

updated 10/15/2013 -tg


  • Note: Pidora seems to be the main portal to fedora 18 on the Raspberry Pi
Direct Download:
pidora koji
"Pidora is a Fedora Remix optimized for the Raspberry Pi computer."
It has its own repos separate from the older RPi-final.img
Install and add Sugar-Deskttop to Pidora
Error creating thumbnail: File missing
  • -Physical Layout of RPi using Wireless Connection and Powered Hub
1-Install Pidora on SD
Insert 8 GB class 4 or 6 SD in USB SD writer
Type mount in root terminal /dev/sdb;/dev/sdc;/dev/sdd should appear in terminal use this value in /dev/sd(x)
cd to directory where you have pidora-18-r2c.img (located inside folder where it was downloaded)
2- Write SD with dd command
[root@localhost pidora-18-r2c]# dd if=pidora-18-r2c.img of=/dev/sd(x)
3500538+0 records in
3500538+0 records out
1792275456 bytes (1.8 GB) copied, 470.625 s, 3.8 MB/s
[root@localhost pidora-18-r2c]# 
3-Unmount SD and Place it in RPi
4-Boot and configure Pidora Pidora_18_Firstboot
After reboot Pidora will pause while it resizes files on SD Card
5-Start Terminal and go to root
Yum install @sugar-desktop 
7-Full screen sugar:
  • logout and log in selecting sugar
* Sugar

XSCE Community School Sever on RPi


"Production of the popular Raspberry Pi computer is switching from China to south Wales."

Coder is a free, open source project that turns a Raspberry Pi into a simple platform that educators and parents can use to teach the basics of building for the web.
New coders can craft small projects in HTML, CSS, and Javascript, right from the web browser.
Fedora 18 Remix:
Good overview of RaspberryPi
Order Page:
New 03/28/2013

Write SD in a MAC:
"...BCM2835 used in the Raspberry Pi is the first ARM-based multimedia SoC with fully-functional,
vendor-provided (as opposed to partial, reverse engineered) fully open-source drivers,..."
RPi resolution fix:"disable_overscan=1"
  • Chromium Browser for RPi (beta)
  • Update and install software before flashing .img using chroot

Projects and Courses

Kernel Testing

Kernel Compilation

Xorg and LXDE
Mate on RPi

Testing Pages

List of Test Pages


Tests of f18/ f17-remixes; Raspbian-PiscesMATE; and rasbian Debian on the RPi

Testing Sweets on a RPi armhf

  • Install of Sweets Sugar 0.94 on a RPi

"RedSleeve is different from CentOS and Scientific Linux in that it isn’t a mere clone of the upstream distribution it is based on
 – it is a port to a new platform, since the upstream distribution does not include a version for ARM."




This ARM port supports the Kirkwood series from Marvell.
Most frequent are: Open-RD, computer plugs (SheevaPlug, GuruPlug).
It runs also in qemu as a virtual machine.
Install to QEMU:
Prebuilt Images:



This is the CuBox-i4P-300-D MAC
Error creating thumbnail: File missing
  • Booted 16 GB microSD:
Inserted under HDMI plug on back

Links for CuBox-i

  • Wiki Main Page IRC Archive for developer discussions
  • Ubuntu
Only low resolution screen Networking works
  • Debian
No networking in tests here
  • Android
Works well
  • Android Recovery
  • XBMC
  • Schematics:

  • XSCE Schoolserver Fedora 20 (experimental)


I ended up writing the FC20Bxxx.img [4][5] with WIN32diskimager[1] after using 7-zip [2] to expand it first.
Instructions from the cubibox wiki [3] to a 16 GB microSD (PNY) class 10; Using a SD adapter in a Yoga-Pro 2 running win 8.1

Error creating thumbnail: File missing

"I have created yet another image.  The last one was just over 8G which forced me to use a 16G sd card because of all the stuff to build the kernel.
I stripped that out, so it now fits in a more manageable 4G card.
For good measure I yum installed git and ansible." Tim Moody 03/17/2014
Error creating thumbnail: File missing
useradd satellit
passwd: xxxxx
It is possible to log in to User satellit on Ctrl Alt F3

Install XSCE

  • Default new install
  • Booted 16 GB microSD:
Inserted under HDMI plug on back
I Write the FC20Bxxx.img [4][5] with WIN32diskimager[1] after using 7-zip [2] to expand it first.
Instructions from the cubibox wiki [3] to a 16 GB microSD (PNY) class 10; Using a SD adapter in a Yoga-Pro 2 running win 8.1
both wired (plugged in) and wireless AP (wep - not logged in) available via apple airport extreme.
  • Login root/fedora
using ansible (runs but not certain will work) 03/20/2014
Installs ansible 1.5
run ./runansible 2 times... hung up on jabber finally restarted and ran ./runansible 2nd time
  • completed install ifconfig
Error creating thumbnail: File missing
Error creating thumbnail: File missing
  • freenode #schoolserver
<timm_> "satellit: you are probably the first to do an install in this configuration. jabber is slow starting and sometimes times out." 03/21/2014
Test 1 Make .img from working 16 GB microSD
03/26/2014 tg
  • root terminal:
dd if=/dev/sdb of=XSCE_schoolserver.img bs=2M
7711+1 records in
7711+1 records out
16172187648 bytes (16 GB) copied, 911.25 s, 17.7 MB/s
  • Compressed to xz makes 2.7 GB file
  • Uncompressed this file and used dd to write the XSCE_schoolserver.img to a 16 GB microSD and it boots.
Tested with XO-1.75
  • Response from alex kleider

Tom, thanks for your response. Based on what I see

"""wlan0   ......
           Mode: managed  Access Point: Not associated

and the fact that it has no IP address, I'm guessing that it's not doing much of anything in its current state but the fact that "Access Point" is even mentioned, suggests that perhaps we can be guardedly optimistic that it might be do-able. Please let me know if you make any progress in this regard. It would probably require low level configuration commands similar to

# We always bootup in AP mode. Delete any stale files
#rm -f /etc/wlanclient.mode
insmod $curdir/mlan.ko
i nsmod $curdir/sd8787.ko drv_mode=2
ifconfig uap0 up
TEST2 ifconfig wlan0
ifconfig wlan0 up
wlan0: flags=4099<up,BROADCAST,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80:422c:f4ff:feae:2144 prefixlen 64 scopeid 0x20<link>
ether 40:2c:f4:ae:21:44 txquelen 1000 (ethernet)s

cheers, alex kleider

Test3 Expand 16GB to 32GB
Used gparted in a fedora laptop SD slot witj SD adapter to expand the 3rd partition on the class 10 microSD to the full 32 GB size.
Booted correctly after the expansion in the CuBox-i4P
  • Note must hit {TAB} and {space} repeatedly to get boot to work?
Hot Plug
with the 3.10 kernel, you can use the eSATA port even if there is no drive enabled when the system boots; add this to the kernel arguments:
Esatap is a single cable supplying power and data, so you want esata+ USB to esatap male
Testing List


  • GitHub


Error creating thumbnail: File missing

Getting Started

BeagleBone Black

  • Plug in the supplied USB cable to your laptop to read the BeagleBone Black on-board files
start.htm file when USB is plugged in: (screenshot below)
  • NOTE click on screenshot to see full size hit <= on browser to retun here
Error creating thumbnail: File missing


"The PengPods are a line of Linux/Android tablets and mini PCs. All devices have an Allwinner A10 or A13 processor. They are designed to run Android on their internal flash and boot Linux from an SD card for the best of both. These devices are hacker friendly and there is an active community working to make them better. You can pre-order a PengPod from our crowd funding project on Indiegogo. "

pengpod as touchscreen for solidoodle 3d printer

"I now have a fully-functional touchscreen pronterface installation that can drive the Solidoodle..."

Ubuntu images for ARM Devices

Ubuntu 13.04 (Raring Ringtail)


Power PC
Doing builds again for fedora 16
  • IRC: #fedora-ppc on


Archlinux on Utilite



"A taste of Sugar on any device"

Archlinux on Trimslice

Complete step by step procedure to install fedora on SD or internal ssd of Chromebook

Automated install of fedora 18


EXPERIMENTAL run Fedora 17 on Chromebook
  • Note danger of blowing out the speakers.

Building your own kernel and installing it in the Chromebook


Recover your Chrome device

Install a new version of the Chrome operating system on your Chrome device by going through the recovery process. You may want to go through this process if you’re having problems updating your Chrome device or if your Chrome device stops working.

Fedora on a Chromebook

  • NEW--Satellit 01:57, 6 December 2012 (EST)


  • ChrUbuntu 12.04 for the new Google Chromebook with ARM processor!

Ubuntu on Chromebook

Debian on Chromebook

  • Entering Developer Mode
"On this device, both the recovery button and the dev-switch have been virtualized.
Our partners don't really like physical switches - they cost money, take up space on the motherboard, and require holes in the case.
To invoke Recovery mode, you hold down the ESC and Refresh keys and poke the Power button.
To enter Dev-mode you first invoke Recovery, and at the Recovery screen press Ctrl-D (there's no prompt - you have to know to do it).
It will ask you to confirm, then reboot into dev-mode.
Dev-mode works the same as always: It will show the scary boot screen and you need to press Ctrl-D or wait 30 seconds to continue booting.
You'll still have to run "crossystem dev_boot_usb=1" and reboot once to boot from USB drives with Ctrl-U. 
To leave Dev-mode and go back to normal mode, just follow the instructions at the scary boot screen. It will prompt you to confirm.
If you want to leave Dev-mode programmatically, you can run "crossystem disable_dev_request=1; reboot" from a root shell  .
Th ere's no way to enter Dev-mode programmatically, and just seeing the Recovery screen isn't enough -  
you have to use the three-finger salute which hard-resets the machine first.
 That's to prevent a remote attacker from tricking your machine into dev-mode without your knowledge.
An unrelated note: Holding just Refresh and poking the Power button hard-resets the machine without entering Recovery.
 That's occasionally useful, but use it with care - it doesn't sync the disk or shut down politely,
 so there's a nonzero chance of trashing the contents of your stateful partition."



  • TESTING Section
  • Hope to install Fedora on it.--Satellit 02:32, 26 October 2012 (EDT)
  • IRC #fedora-arm freenode


Detailed instructions:


SoaS in Parallels for OS X

(Not very current)

Sugar Patches